Back to overview
Direct Install Certificate Partially Down
Jan 30, 2026 at 08:58pm UTC
Affected services
Direct Install
Resolved
Jan 30, 2026 at 08:58pm UTC
The unofficial direct install is currently up
Affected services
Resolved
Jan 30, 2026 at 08:58pm UTC
The unofficial direct install is currently up
Affected services